vcs

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category General
  • Assigned To
    Toni Corvera
  • Operating System
  • Severity Medium
  • Priority Low
  • Reported Version 1.12.2
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: vcs
Opened by Toni Corvera - 13.09.2010
Last edited by Toni Corvera - 13.09.2010

FS#175 - Failure after a certain number of uses

Originally reported by Robert Speicher.

Works for awhile, then starts failing until reboot. Happens with 1.12.1, but continued to fail after upgrade to 1.12.2.

Log:

Video Contact Sheet *NIX v1.12.1, (c) 2007-2010 Toni Corvera
Timestamps disabled.
Shadows disabled.
Padding disabled.
Processing Video.avi...
Capturing in range [01:12.50-19:30.00]. Total length: 20:26.02
Generating capture #1/16 (01:22.50)...
Generating capture #2/16 (02:35.00)...
Generating capture #3/16 (03:47.50)...
Generating capture #4/16 (05:00.00)...
Generating capture #5/16 (06:12.50)...
Generating capture #6/16 (07:25.00)...
Generating capture #7/16 (08:37.50)...
Generating capture #8/16 (09:50.00)...
Generating capture #9/16 (11:02.50)...
Generating capture #10/16 (12:15.00)...
Generating capture #11/16 (13:27.50)...
Generating capture #12/16 (14:40.00)...
Generating capture #13/16 (15:52.50)...
Generating capture #14/16 (17:05.00)...
Generating capture #15/16 (18:17.50)...
Generating capture #16/16 (19:30.00)...
Composing standard contact sheet...
Adding header and footer...
Done. Output wrote to Video.avi.jpg
Cleaning up...
Video Contact Sheet *NIX v1.12.1, (c) 2007-2010 Toni Corvera
Timestamps disabled.
Shadows disabled.
Padding disabled.
Processing Video.avi...
Capturing in range [02:16.25-36:30.00]. Total length: 37:15.80
Generating capture #1/16 (02:26.25)...
Generating capture #2/16 (04:42.50)...
Generating capture #3/16 (06:58.75)...
Generating capture #4/16 (09:15.00)...
Generating capture #5/16 (11:31.25)...
Generating capture #6/16 (13:47.50)...
Generating capture #7/16 (16:03.75)...
Generating capture #8/16 (18:20.00)...
Generating capture #9/16 (20:36.25)...
Generating capture #10/16 (22:52.50)...
Generating capture #11/16 (25:08.75)...
Generating capture #12/16 (27:25.00)...
Generating capture #13/16 (29:41.25)...
Generating capture #14/16 (31:57.50)...
Generating capture #15/16 (34:13.75)...
Generating capture #16/16 (36:30.00)...
Composing standard contact sheet...
Adding header and footer...
Done. Output wrote to Video.avi.jpg
Cleaning up...
Video Contact Sheet *NIX v1.12.1, (c) 2007-2010 Toni Corvera
Timestamps disabled.
Shadows disabled.
Padding disabled.
Processing Video.avi...
Capturing in range [00:50.00-13:30.00]. Total length: 14:02.64
Generating capture #1/16 (01:00.00)...
Generating capture #2/16 (01:50.00)...
Generating capture #3/16 (02:40.00)...
Generating capture #4/16 (03:30.00)...
Generating capture #5/16 (04:20.00)...
Generating capture #6/16 (05:10.00)...
Generating capture #7/16 (06:00.00)...
Generating capture #8/16 (06:50.00)...
Generating capture #9/16 (07:40.00)...
Generating capture #10/16 (08:30.00)...
Generating capture #11/16 (09:20.00)...
Generating capture #12/16 (10:10.00)...
Generating capture #13/16 (11:00.00)...
Generating capture #14/16 (11:50.00)...
Generating capture #15/16 (12:40.00)...
Generating capture #16/16 (13:30.00)...
Composing standard contact sheet...
montage: WriteBlob Failed `/dev/shm/vcs.rYHunk/vcs-MKciWX.png' @ coders/png.c/PNGErrorHandler/1391.
convert: Expected 8192 bytes; found 7332 bytes `/dev/shm/vcs.rYHunk/vcs-MKciWX.png' @ coders/png.c/PNGWarningHandler/1408.
convert: Read Exception `/dev/shm/vcs.rYHunk/vcs-MKciWX.png' @ coders/png.c/PNGErrorHandler/1391.
convert: Corrupt image `/dev/shm/vcs.rYHunk/vcs-MKciWX.png' @ coders/png.c/ReadPNGImage/2877.
convert: missing an image filename `/dev/shm/vcs.rYHunk/vcs-MKciWX.png' @ wand/convert.c/ConvertImageCommand/2710.
identify: Expected 8192 bytes; found 7332 bytes `/dev/shm/vcs.rYHunk/vcs-MKciWX.png' @ coders/png.c/PNGWarningHandler/1408.
identify: Read Exception `/dev/shm/vcs.rYHunk/vcs-MKciWX.png' @ coders/png.c/PNGErrorHandler/1391.
identify: Corrupt image `/dev/shm/vcs.rYHunk/vcs-MKciWX.png' @ coders/png.c/ReadPNGImage/2877.
identify: Expected 8192 bytes; found 7332 bytes `/dev/shm/vcs.rYHunk/vcs-MKciWX.png' @ coders/png.c/PNGWarningHandler/1408.
identify: Read Exception `/dev/shm/vcs.rYHunk/vcs-MKciWX.png' @ coders/png.c/PNGErrorHandler/1391.
identify: Corrupt image `/dev/shm/vcs.rYHunk/vcs-MKciWX.png' @ coders/png.c/ReadPNGImage/2877.
/usr/bin/vcs: line 3320: ( - ) / 2 : syntax error: operand expected (error token is ") / 2 ")
Cleaning up...
Video Contact Sheet *NIX v1.12.1, (c) 2007-2010 Toni Corvera
Timestamps disabled.
Shadows disabled.
Padding disabled.
Processing Video.avi...
Capturing in range [00:53.75-14:30.00]. Total length: 15:46.15
Generating capture #1/16 (01:03.75)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-rUCuNH.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #2/16 (01:57.50)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-zZbLrH.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #3/16 (02:51.25)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-jtjSCK.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #4/16 (03:45.00)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-OPrsFE.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #5/16 (04:38.75)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-yTKhKY.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #6/16 (05:32.50)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-qNZBGT.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #7/16 (06:26.25)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-BMvDIJ.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #8/16 (07:20.00)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-LIiceG.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #9/16 (08:13.75)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-Mirxow.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #10/16 (09:07.50)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-MTumnX.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #11/16 (10:01.25)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-Fmbspn.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #12/16 (10:55.00)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-EpyojU.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #13/16 (11:48.75)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-xaWRsM.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #14/16 (12:42.50)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-SWjaOd.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #15/16 (13:36.25)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-RPgswJ.png' @ coders/png.c/PNGErrorHandler/1391.
Generating capture #16/16 (14:30.00)...
convert: WriteBlob Failed `/dev/shm/vcs.EgedHO/vcs-UcJOwe.png' @ coders/png.c/PNGErrorHandler/1391.
Composing standard contact sheet...
montage: Expected 8192 bytes; found 4013 bytes `/dev/shm/vcs.EgedHO/vcs-vUkjQs-cap-000001.png' @ coders/png.c/PNGWarningHandler/1408.
montage: Read Exception `/dev/shm/vcs.EgedHO/vcs-vUkjQs-cap-000001.png' @ coders/png.c/PNGErrorHandler/1391.
montage: Corrupt image `/dev/shm/vcs.EgedHO/vcs-vUkjQs-cap-000001.png' @ coders/png.c/ReadPNGImage/2877.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-fyBsXW-cap-000002.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-KaORtG-cap-000003.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-XpQLft-cap-000004.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-JJOrHH-cap-000005.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-njxEmD-cap-000006.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-spNKJs-cap-000007.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-ShRSMS-cap-000008.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-dVzzbj-cap-000009.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-tDyUTy-cap-000010.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-ZhPdxF-cap-000011.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-KNPGcw-cap-000012.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-fpoOpZ-cap-000013.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-xQKSPT-cap-000014.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-jiQomq-cap-000015.png' @ coders/png.c/ReadPNGImage/2839.
montage: Improper image header `/dev/shm/vcs.EgedHO/vcs-gwGaCZ-cap-000016.png' @ coders/png.c/ReadPNGImage/2839.
montage: missing an image filename `/dev/shm/vcs.EgedHO/vcs-pIBUGe.png' @ wand/montage.c/MontageImageCommand/1596.
convert: missing an image filename `/dev/shm/vcs.EgedHO/vcs-pIBUGe.png' @ wand/convert.c/ConvertImageCommand/2710.
/usr/bin/vcs: line 3320: ( - ) / 2 : syntax error: operand expected (error token is ") / 2 ")
Cleaning up...
Video Contact Sheet *NIX v1.12.1, (c) 2007-2010 Toni Corvera
Timestamps disabled.
Shadows disabled.
Padding disabled.
Processing Video.avi...
Detected video length can't be reached. Safe measuring enabled.
Starting safe length measuring (this might take a while)...
   ... trying 1724.759
   ... trying 1724.259
   ... trying 1723.759
   ... trying 1723.259
   ... trying 1722.759
   ... trying 1722.259
   ... trying 1721.759
   ... trying 1721.259
   ... trying 1720.759
   ... trying 1720.259
   ... trying 1719.759
   ... trying 1719.259
   ... trying 1718.759
   ... trying 1718.259
   ... trying 1717.759
   ... trying 1717.259
   ... trying 1716.759
   ... trying 1716.259
   ... trying 1715.759
   ... trying 1715.259
   ... trying 1714.759
   ... trying 1714.259
   ... trying 1713.759
   ... trying 1713.259
   ... trying 1712.759
   ... trying 1712.259
   ... trying 1711.759
   ... trying 1711.259
   ... trying 1710.759
   ... trying 1710.259
   ... trying 1709.759
   ... trying 1709.259
   ... trying 1708.759
   ... trying 1708.259
   ... trying 1707.759
   ... trying 1707.259
   ... trying 1706.759
   ... trying 1706.259
   ... trying 1705.759
   ... trying 1705.259
Couldn't measure length in a reasonable amount of tries.
  Capturing won't work, video is at least 00:20.00 shorter than reported.
   Does ffmpeg support XVID?.
   Try re-running with -Ws -WP.
Failure while analysing file "Video.avi". Can't continue.
Cleaning up...
Video Contact Sheet *NIX v1.12.1, (c) 2007-2010 Toni Corvera
Timestamps disabled.
Shadows disabled.
Padding disabled.
Processing Video.avi...
Detected video length can't be reached. Safe measuring enabled.
Starting safe length measuring (this might take a while)...
   ... trying 1614.210
   ... trying 1613.710
   ... trying 1613.210
   ... trying 1612.710
   ... trying 1612.210
   ... trying 1611.710
   ... trying 1611.210
   ... trying 1610.710
   ... trying 1610.210
   ... trying 1609.710
   ... trying 1609.210
   ... trying 1608.710
   ... trying 1608.210
   ... trying 1607.710
   ... trying 1607.210
   ... trying 1606.710
   ... trying 1606.210
   ... trying 1605.710
   ... trying 1605.210
   ... trying 1604.710
   ... trying 1604.210
   ... trying 1603.710
   ... trying 1603.210
   ... trying 1602.710
   ... trying 1602.210
   ... trying 1601.710
   ... trying 1601.210
   ... trying 1600.710
   ... trying 1600.210
   ... trying 1599.710
   ... trying 1599.210
   ... trying 1598.710
   ... trying 1598.210
   ... trying 1597.710
   ... trying 1597.210
   ... trying 1596.710
   ... trying 1596.210
   ... trying 1595.710
   ... trying 1595.210
   ... trying 1594.710
Couldn't measure length in a reasonable amount of tries.
  Capturing won't work, video is at least 00:20.00 shorter than reported.
   Does ffmpeg support XVID?.
   Try re-running with -Ws -WP.
Failure while analysing file "Video.avi". Can't continue.

Every capture from here on out will fail in a similar fashion until reboot.
Closed by  Toni Corvera
13.09.2010 16:28
Reason for closing:  Duplicate
Additional comments about closing:  

Duplicate of  FS#167 

Project Manager
Toni Corvera commented on 13.09.2010 16:28

Duplicate of  FS#167 . Happening in 1.12.2 too since the upgrade was made after /dev/shm had been filled.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing