vcs

  • Status Closed
  • Percent Complete
    100%
  • Task Type TO-DO
  • Category General
  • Assigned To
    Toni Corvera
  • Operating System
  • Severity Low
  • Priority Very Low
  • Reported Version Not applicable
  • Due in Version 1.12.3
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: vcs
Opened by Toni Corvera - 27.08.2010
Last edited by Toni Corvera - 17.07.2011

FS#173 - Switch to Bash 3

Bash 2 syntax has been the norm for most versions (although broken in some).

So far none of the major distributions is using bash 2, bash 4 is already gold but not widely-used enough.

Only a few special purpose/minimal distros like DSL retain bash 2.05b, but vcs requires recent versions of ImageMagick, Mplayer and FFmpeg anyway. I can’t see a reason to retain such backwards compatibility.

The task blocks this from closing
ID Project Summary Priority Severity Progress
170 vcs  FS#170 - Release 1.12.3  Defer Very Low
100%
Closed by  Toni Corvera
17.07.2011 17:12
Reason for closing:  Implemented
Additional comments about closing:  

Done in 1.12.3

Project Manager
Toni Corvera commented on 27.08.2010 17:04

1.12.3 will start the switch to separate it from other major changes in 1.13.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing